Compiling newLISP on Ubuntu 14.04 ARM

Machine-specific discussion
Unix, Linux, OS X, OS/2, Windows, ..?

Compiling newLISP on Ubuntu 14.04 ARM

Postby mahasamoot » Tue Jan 12, 2016 10:21 pm

I have an ARM Chromebook with Ubuntu 14.04 "Trusty" running in a chroot. It seems that a newLISP package isn't available for ARM. Thus I downloaded and compiled from source. It compiled just fine with no errors or warnings reported (though I couldn't get readline support working). However, when I did a 'make test' I get this error reported:

>>>>> TESTING: ./newlisp FINISHED WITH ERRORS:
>>>> struct failed ERR: ffi struct expected in function pack

It passed all the other tests.
mahasamoot
 
Posts: 1
Joined: Tue Jan 12, 2016 6:48 pm

Return to newLISP and the O.S.

Who is online

Users browsing this forum: No registered users and 1 guest