newLisp on Yosemite (Mac OS X.10)

Machine-specific discussion
Unix, Linux, OS X, OS/2, Windows, ..?

newLisp on Yosemite (Mac OS X.10)

Postby mbartz » Fri Oct 24, 2014 10:36 pm

After upgrading to Yosemite (10.10), NewLisp now prompts to install Java SE 6 runtime. Is there a configuration so that I don't have to install the Java SE 6 runtime and use Java 8?
mbartz
 
Posts: 9
Joined: Mon Apr 29, 2013 1:02 pm

Re: newLisp on Yosemite (Mac OS X.10)

Postby mbartz » Fri Oct 24, 2014 10:41 pm

The installation of java se 6 was pretty easy via the apple support site. I was just curious if newLisp was going to target Java 8.
mbartz
 
Posts: 9
Joined: Mon Apr 29, 2013 1:02 pm

Re: newLisp on Yosemite (Mac OS X.10)

Postby Lutz » Sat Oct 25, 2014 7:22 am

The newLISP IDE was running fine on Java 7, on Java 8 nobody ever complained and most likely it will just work.

Yosemete OSX 10.10 comes with no Java installed at all and I think the prompt for Java 6 will happen to any java program trying to start on OSX starting with Maverick. Prompting for Java version 6 is not newLISP specific, it is just the last Java version ever shipped by Apple. Try installing Java 8 as well and try running again. Somewhere on OSX there is also a smal control app to switch between Java versions. Also, the minimum version required for newLISP guiserver.jar is Java 6.

ps: Java 8 works on Windows
Lutz
 
Posts: 5258
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California


Return to newLISP and the O.S.

Who is online

Users browsing this forum: No registered users and 1 guest

cron