newlisp windows version and mysql

Machine-specific discussion
Unix, Linux, OS X, OS/2, Windows, ..?

newlisp windows version and mysql

Postby cax » Mon Aug 25, 2014 3:53 pm

Hi,
I'm a newbie.
I installed v.10.6.0 (Win32 installer v.10.6.0), since I'm using window7.
mysql version 5.6
when using (module 'mysql.lsp'), I got the error message as "cannot find libmysqlclient library".
I can't find this file in mysql.
Appreciate your advice :)
cax
 
Posts: 3
Joined: Mon Aug 25, 2014 3:40 pm

Re: newlisp windows version and mysql

Postby Lutz » Mon Aug 25, 2014 5:02 pm

Lutz
 
Posts: 5258
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: newlisp windows version and mysql

Postby cax » Tue Aug 26, 2014 3:10 am

Hi Lutz,

Thank you for the answer.
Are you suggesting me reinstall mysql or mysql-connector?

cax
cax
 
Posts: 3
Joined: Mon Aug 25, 2014 3:40 pm

Re: newlisp windows version and mysql

Postby Lutz » Tue Aug 26, 2014 4:11 am

Looking through the linked page, I realize that this looks very different from running MySQL on Mac OS X or Linux or other Unix. I have never used MySQL on Windows. Perhaps somebody else on this board has experience running MySQL with newLISP on Windows and can help you. Maybe the ODBC interface will work with the odbc.lsp module in the newLISP distribution.
Lutz
 
Posts: 5258
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: newlisp windows version and mysql

Postby cax » Tue Aug 26, 2014 5:46 am

Thank you Lutz. The odbc.lsp loaded. :)
Trying to connect to my database.
cax
 
Posts: 3
Joined: Mon Aug 25, 2014 3:40 pm


Return to newLISP and the O.S.

Who is online

Users browsing this forum: No registered users and 1 guest

cron