I/O error

Machine-specific discussion
Unix, Linux, OS X, OS/2, Windows, ..?
Post Reply
Darth_Severus
Posts: 18
Joined: Fri Aug 08, 2014 6:08 pm

I/O error

Post by Darth_Severus »

Hi,

I'm recently getting an I/O error when trying to start newLisp:
$ /usr/bin/newlisp

ERR: I/O error
I didn't change anything, it just happend. Didn't try a new install so far. Any ideas why this happend?
$ file /usr/bin/newlisp
/usr/bin/newlisp: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.26, BuildID[sha1]=6e58352d03112cf6cf1deb50fc8186415bf68610, stripped
CPU~Dual core Intel Core2 Duo U7600 (-MCP-) speed/max~800/1201 MHz Kernel~3.14-0.bpo.2-686-pae i686 Up~5 days Mem~620.3/999.6MB

ralph.ronnquist
Posts: 223
Joined: Mon Jun 02, 2014 1:40 am
Location: Melbourne, Australia

Re: I/O error

Post by ralph.ronnquist »

If possible, try running it with strace

Code: Select all

strace /usr/bin/newlisp |& tee LOG
Then reduce the LOG file to the stat, open and error lines with

Code: Select all

egrep '(stat|open|ERR)' LOG
Doing that might give a lead to where the problem arises.

Darth_Severus
Posts: 18
Joined: Fri Aug 08, 2014 6:08 pm

Re: I/O error

Post by Darth_Severus »

Thanks ralf, this was a good idea. I should have had that thought on my own. Next time I'm trying strace. However, my computer froze and I had to restart. Now it is working.

ValentiMr
Posts: 3
Joined: Tue Aug 27, 2019 12:18 am
Location: Ukraine

-

Post by ValentiMr »

So .. after complete HDD eration, still have problems with freezing and crashing and stuff. It gives me error 487 .... what to do next? Win10 64 bit is system. Tnx for help.

ValentiMr
Posts: 3
Joined: Tue Aug 27, 2019 12:18 am
Location: Ukraine

hi!

Post by ValentiMr »

If possible, try running it with strace Code: Select allstrace /usr/bin/newlisp |& tee LOG

The nice answer!

Post Reply