[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
newlispfanclub.alh.net • View topic - newLISP Development Release v.10.5.6

newLISP Development Release v.10.5.6

Notices and updates

newLISP Development Release v.10.5.6

Postby Lutz » Tue Dec 10, 2013 4:26 pm

Development release v.10.5.6 continues with many small additions and improvements in several areas:

Files and changes notes: http://www.newlisp.org/downloads/development/
Lutz
 
Posts: 5279
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: newLISP Development Release v.10.5.6

Postby johu » Thu Dec 12, 2013 11:50 am

Last edited by johu on Fri Dec 13, 2013 9:35 am, edited 1 time in total.
johu
 
Posts: 143
Joined: Mon Feb 08, 2010 8:47 am

Re: newLISP Development Release v.10.5.6

Postby Lutz » Thu Dec 12, 2013 3:11 pm

Thanks Johu, the new translation is online:

http://www.newlisp.org/downloads/develo ... al-jp.html


but I could only find the syztem spelling error and not the misplaced <b]sort bold quotes. Did you work using the latest newlisp_manial.html 10.5.6, as posted yesterday?
Lutz
 
Posts: 5279
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: newLISP Development Release v.10.5.6

Postby johu » Fri Dec 13, 2013 9:45 am

Thank you for response, Lutz.

And I'm sorry, my explanation was not enough and using bold-tags had been wrong.

Then, I will be more careful.
johu
 
Posts: 143
Joined: Mon Feb 08, 2010 8:47 am

Re: newLISP Development Release v.10.5.6

Postby Lutz » Fri Dec 13, 2013 4:04 pm

Thanks for the great work Johu! I wish we had translations into more languages, but it is a lot of work. When printed, the manual is now over 300 pages long.
Lutz
 
Posts: 5279
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: newLISP Development Release v.10.5.6

Postby TedWalther » Tue Dec 17, 2013 2:31 am

Lutz, does the FFI implementation in newlisp really need to depend on version 3.0.10 or later?

I did some digging, and it seems libffi 3.0.9 is fine, but breaks not only on OpenBSD, but also on Solaris and NetBSD. So far those platforms are sticking with 3.0.9, but adding patches to make it support various hardware architectures.

Was the shift from 3.0.9 to 3.0.10 that big, or could there be some way of supporting 3.0.9?
Cavemen in bearskins invaded the ivory towers of Artificial Intelligence. Nine months later, they left with a baby named newLISP. The women of the ivory towers wept and wailed. "Abomination!" they cried.
TedWalther
 
Posts: 605
Joined: Mon Feb 05, 2007 1:04 am
Location: Abbotsford, BC

Re: newLISP Development Release v.10.5.6

Postby Lutz » Tue Dec 17, 2013 2:54 pm

Judging from your error messages on OpenBSD with libffi 3.0.9, it looks like the current code in newLISP needs some functions which are not available in 3.0.9. But if you say, you could make 3.0.9 work with newLISP on other platforms, then the OpenBSD problem perhaps is of different nature?

On this page: https://sourceware.org/libffi/ version 3.0.13 is listed as working with OpenBSD. That sounds like 30.0.13 should be installable on OpenBSD? 3.0.9 was released in December 2009. Stefan Sonnenberg, who wrote the initial libffi support in newLISP, based it on 3.0.10 released in August 2011.
Lutz
 
Posts: 5279
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: newLISP Development Release v.10.5.6

Postby TedWalther » Wed Dec 18, 2013 3:39 am

I guess to update the OpenBSD port of newlisp now I'll have to help the maintainers of libffi too. Ok. sigh. Hopefully I get it done in time for the big stable release of newlisp.
Cavemen in bearskins invaded the ivory towers of Artificial Intelligence. Nine months later, they left with a baby named newLISP. The women of the ivory towers wept and wailed. "Abomination!" they cried.
TedWalther
 
Posts: 605
Joined: Mon Feb 05, 2007 1:04 am
Location: Abbotsford, BC

Re: newLISP Development Release v.10.5.6

Postby abaddon1234 » Sat Apr 02, 2016 12:47 pm

it looks like the current code in newLISP
abaddon1234
 
Posts: 21
Joined: Mon Sep 14, 2015 3:09 am

Re: newLISP Development Release v.10.5.6

Postby TedWalther » Sat Apr 02, 2016 5:45 pm

Have you checked if libffi support is enabled? I know a while ago they updated libffi to one that works with newLisp. I haven't had time or energy to update my OpenBSD build server, so I haven't been able to test this.
Cavemen in bearskins invaded the ivory towers of Artificial Intelligence. Nine months later, they left with a baby named newLISP. The women of the ivory towers wept and wailed. "Abomination!" they cried.
TedWalther
 
Posts: 605
Joined: Mon Feb 05, 2007 1:04 am
Location: Abbotsford, BC


Return to newLISP newS

Who is online

Users browsing this forum: No registered users and 1 guest

cron