Page 1 of 1

Guiserver again

PostPosted: Sun Apr 17, 2016 6:54 pm
by jazper
Hi all. With a new installation of Ubuntu 15.04, I installed java (not the jre that comes with ubuntu) from Oracle, as shown in the downloads page. The result is that the java executable is found at
/usr/bin/java/jre1.8.0_77/bin/java


I then created a link, with
sudo ln -s /usr/bin/java/jre1.8.0_77/bin/java /usr/bin/java


This however does not find guiserver.jar when
newlisp-edit
is typed. Am I linking incorrectly? The newlisp executable is in /usr/local/bin

Re: Guiserver again

PostPosted: Tue Apr 19, 2016 1:25 pm
by Lutz
On OS X and all other Unix/Linux newlisp-edit looks for NEWLISPDIR/guiserver.jar, where NEWLISPDIR is defined as /usr/local/share/newlisp on newlisp startup, except when NEWLISPDIR is already defined in the environment, then that definition is not changed when newlisp starts.

You also can start newlisp-edit by starting guiserver.jar first:

Code: Select all
java -jar /usr/local/share/newlisp/guiserver.jar 64001 /usr/local/bin/newlisp-edit


or use 47011 or any other free portnumber greater 1024.

Ps: portno + 1 will also be used so for 64001, 64001 and 64002 will be used etc.

Re: Guiserver again

PostPosted: Tue Apr 19, 2016 7:36 pm
by jazper
Thanks for the NEWLISPDIR tip. I will try setting that. However, this java response has dogged me for days: any attempt to call java results in this response in the terminal:
The program 'java' can be found in the following packages:
* default-jre
* gcj-4.9-jre-headless
* gcj-5-jre-headless
* openjdk-7-jre-headless
* gcj-4.8-jre-headless
* openjdk-6-jre-headless
* openjdk-8-jre-headless
Try: sudo apt-get install <selected package>


I even tried it with these installed, with the same result.

Re: Guiserver again

PostPosted: Wed Apr 20, 2016 2:14 pm
by jazper
Setting NEWLISPDIR does not help:
NEWLISPDIR=/usr/local/share/newlisp
export NEWLISPDIR
is what I do.

The java problem remains.

Re: Guiserver again

PostPosted: Wed Apr 20, 2016 3:00 pm
by jazper
NEWLISPDIR does not persist. I set it and restart, and it's not there using
printenv
or
printenv NEWLISPDIR


There are a confusing number of totally different posts on askbuntu on how to set it on startup, (~/.profile, ~/.local.rc, ~/.pam_environment, and some files in /etc) all of which I have tried, and none work.

Anyhow, even after setting it for a terminal session and checking that it still there, it doesn't change things

Re: Guiserver again

PostPosted: Thu Apr 21, 2016 5:20 am
by jazper
I was wrong about one thing: the version. I am on Ubuntu 15.10

Re: Guiserver again

PostPosted: Sun Jul 10, 2016 8:44 pm
by jazper
This problem sorted itself out somehow. I'm on Ubuntu 16.04. I installed newLISP from the download. After not getting the GuiServer to work, I left things for these few months, & had my newLISP fun on windows. Then, I found a post on how to install Oracle Java on Ubuntu 16.04. I followed that, & the guiserver just worked. It was not necessary to create a symlink.

See https://www.digitalocean.com/community/tutorials/how-to-install-java-with-apt-get-on-ubuntu-16-04