[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
newlispfanclub.alh.net • View topic - Buttonhandler does not work when empty field

Buttonhandler does not work when empty field

Guiserver, GTK-server, OpenGL, PostScript,
HTML 5, MIDI, IDE

Buttonhandler does not work when empty field

Postby hotcore » Fri Aug 10, 2012 12:00 pm

hotcore
 
Posts: 29
Joined: Fri Aug 26, 2011 1:03 pm

Re: Buttonhandler does not work when empty field

Postby hotcore » Fri Aug 10, 2012 5:10 pm

It seems that, when you don't do a set-text for a text-field (or fill it in in the form manually) that get-text for that text-field gets stuck somehow.

The same behavior occurs when you empty the text-field at some stage (delete all chars in it).

Any ideas?

Thx,
Arie
hotcore
 
Posts: 29
Joined: Fri Aug 26, 2011 1:03 pm

Re: Buttonhandler does not work when empty field

Postby Lutz » Fri Aug 10, 2012 7:48 pm

Lutz
 
Posts: 5279
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: Buttonhandler does not work when empty field

Postby hotcore » Sat Aug 11, 2012 9:51 am

Thanks Lutz!

I already tried that. But when the user empties the field, the same problem will still occur ...

Is there a way (apart from get-text) to see if a field is in such an uninitialized state?

BTW many thanks for this wonderful language!
hotcore
 
Posts: 29
Joined: Fri Aug 26, 2011 1:03 pm

Re: Buttonhandler does not work when empty field

Postby Lutz » Sat Aug 11, 2012 4:19 pm

The relevant function in the text-field widget in guiserver.jar was not handling empty text correctly when text was requested via gs:get-text.

This is now fixed in version 1.47 of Guiserver available here:

http://www.newlisp.org/downloads/develo ... server.jar

Ps: there will also be a newLISP maintenance release 10.4.4 in September, where the fixed guiserver.jar will be included.
Lutz
 
Posts: 5279
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: Buttonhandler does not work when empty field

Postby hotcore » Sat Aug 11, 2012 6:15 pm

Wow, Lutz you are a genius ;-)
Thanks a lot for the quick fix!

/Arie
hotcore
 
Posts: 29
Joined: Fri Aug 26, 2011 1:03 pm


Return to newLISP Graphics & Sound

Who is online

Users browsing this forum: No registered users and 1 guest