java message on GS load

Guiserver, GTK-server, OpenGL, PostScript,
HTML 5, MIDI, IDE

java message on GS load

Postby jazper » Wed Apr 11, 2012 3:44 pm

Greetings.

I get a strange message on loading the ide (after typing "newlisp-edit") on terminal command line:

Code: Select all
(java:3058): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",


It doesn't seem to harm anything. I am merely curious, and don't know the first thing about java. Distro is Ubuntu 11.10.
jazper
 
Posts: 91
Joined: Thu Dec 10, 2009 8:26 am
Location: South Africa

Re: java message on GS load

Postby Lutz » Thu Apr 12, 2012 12:27 am

Do not run the Java which come on the standard UBUNTU install. Instead load down Java SE or Java RTE from:

http://java.com/en/download/index.jsp

click on Download and get the "Linux (self extracting file)"

then install it in /usr/local

then make a symbolic link from /usr/local/jre.x.x.x-java/bin/java to /usr/bin/java.

Instead of the JRE (Java Runtime Environment) you can also get the full JDK (Java Development Kit)
Lutz
 
Posts: 5258
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: java message on GS load

Postby jazper » Sun Apr 29, 2012 8:27 pm

For information:

I never got around to replacing the java that comes with Ubuntu. Then I upgraded from Ubuntu 11.10 to 12.04 a few days ago. After the upgrade, the java error messages no longer appear when loading newLISP GS IDE server. Saved me the trouble.
jazper
 
Posts: 91
Joined: Thu Dec 10, 2009 8:26 am
Location: South Africa

solved java errors - Ubuntu Precise Pangolin

Postby jazper » Sun Apr 29, 2012 8:46 pm

After Ubuntu Precise Pangolin solved the java GTK message problem, it was otherwise a very pleasant upgrade for me. The Unity loader works without problems now, but what's really great is the new Heads Up Display replacing menus. I click the Windows key, and the HUD overlays the desktop in transparency, displaying recent apps, recent files, and recent downloads. Typing "GI" offers me the Gimp's Icon, a click loads it.

I downloaded an app called Main Menu from the Software Center. Using that I added Newlisp to Unity. It was simple: enter the "newlisp-edit" command in the right input box, fill in the other details in the dialog, click on the icon in the dialog and browse to /usr/share/newlisp to select the newLISP icon & close. Then, pressing the Windows key and entering "Ne" brought up the newLISP icon. I think Ubuntu has really stolen a march on both Windows and Apple for ease of use here. I really don't enjoy too much clicking around endless menus with a mouse (and use a tablet instead of mouse when I can), so this ability to type (without needing to load a terminal first) is a steal to me. Speaking of which, I just plugged in my Wacom Bamboo tablet to this Ubuntu 12.04 (it's an HP laptop) computer, and it works straight off without a hitch. Win 7 struggled with that, and then downloaded a driver, which didn't work first time, but it eventually did the second time. I'm impressed.
jazper
 
Posts: 91
Joined: Thu Dec 10, 2009 8:26 am
Location: South Africa

Re: java message on GS load

Postby Lutz » Mon Apr 30, 2012 12:06 am

Thanks for the note. I also just installed 12.04 in VirtualBox on Mac OSX Lion. And the Java installed on this version of UBUNTU works fine. Only the main menu in the newLISP-GS IDE was hardly visible because of the dark colors in the default UBUNTU theme. But switching to the "Radiance" theme solved the problem.

But I still have problems with the sound for midi-demo.lsp and midi2-demo.lsp. Even after installing "soundbank-mid.gm", it was not able to do a gs:midi-init with that file. Perhaps you find a solution for this ;-)

ps: also just updated http://www.newlisp.org/modules/various/plot.lsp.html with a new function for XY plots.

ps: and updated again ... clear your browser cache.
Lutz
 
Posts: 5258
Joined: Thu Sep 26, 2002 4:45 pm
Location: Pasadena, California

Re: java message on GS load

Postby jazper » Mon Apr 30, 2012 5:32 pm

Thanks to you too. I had not noticed a problem, but checked now to find I had already switched to "radiance".

As to sound, I have always struggled with both midi demo programs, and in fact with sound on Ubuntu, throughout the years. I will give them a try, and report back.
jazper
 
Posts: 91
Joined: Thu Dec 10, 2009 8:26 am
Location: South Africa

Midi demos on Ubuntu 12.04

Postby jazper » Tue May 01, 2012 1:32 pm

Without making any changes since upgrading, both newLISP midi demos at least now do something.

midi-demo.lsp brings up a message box
Code: Select all
gs:midi-patch - instrument not known

When I press OK, it then plays the programmed scale sequence, on a piano. But maybe the piano is a default.

midi2-demo.lsp does the same thing, but after pressing ok, it plays only a few of the programmed sounds. Without ever doing anything with midi and synthesizers, I don't know why this is happening as it is, but I am wildly thrilled at getting any kind of sound at all!
jazper
 
Posts: 91
Joined: Thu Dec 10, 2009 8:26 am
Location: South Africa


Return to newLISP Graphics & Sound

Who is online

Users browsing this forum: No registered users and 2 guests

cron