Search found 108 matches

by dukester
Fri Apr 12, 2019 2:16 pm
Forum: newLISP Graphics & Sound
Topic: guiserver wont run on Win10
Replies: 1
Views: 2032

guiserver wont run on Win10

Not for me anyway!

c:\bin\newlisp>newlisp
newLISP v.10.7.1 64-bit on Windows IPv4/6 UTF-8 libffi, options: newlisp -h

> (load "guiserver.lsp")
(lambda (gs:id gs:action) (net-send gs:out (string "frame-resized " gs:id " " gs:action "\n")))
>
by dukester
Sat Apr 06, 2019 5:06 am
Forum: newLISP and the O.S.
Topic: How to stop newlisp in daemon mode
Replies: 2
Views: 1781

Re: How to stop newlisp in daemon mode

@Hans-Peter Thanks! I'll check into it further! In the meantime, I have been "Ending the Task" using Windoze Task Manager. I appreciate your input!
by dukester
Fri Apr 05, 2019 7:30 pm
Forum: newLISP and the O.S.
Topic: How to stop newlisp in daemon mode
Replies: 2
Views: 1781

How to stop newlisp in daemon mode

I've been running newlisp -http -d8080 etc etc

I haven't anything in the manual that indicates how to gracefully shutdown newlisp in daemon mode on a windows box.
by dukester
Wed Apr 03, 2019 10:42 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

Problem solved! I configured Apache to run as a reverse proxy on a sub-directory to my cgi-bin containing newlisp scripts. I run newlisp as -http -d 8080 -w <full\path\to\cgi-bin\newLISP> In Apache httpd.conf, simply load: mod_proxy.so mod_proxy_http.so mod_proxy_http2.so and insert the following d...
by dukester
Sat Mar 30, 2019 1:23 am
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

I've got TMP/tmp/temp set in so many places that all hell wont have it. BTW I never get this bleeding tmp issue with any other script.
by dukester
Fri Mar 29, 2019 11:27 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

Yeah! I realized that you meant me! I was just trying to be civil and say "No $%%^^* way!!" LOL And Lutz does have better things to do! Thanks - I will fiddle with it as and when the mood hits me. Good luck yourself!
by dukester
Fri Mar 29, 2019 10:06 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

@rickyboy You know - I'm thinking that Lutz has already wasted enough time looking into this issue. If there were hundreds of folks using newlisp on Apache, it might then be a worthwhile investment of time. I'm sure that the folks at Apache would pretty much feel the same way! How many people are th...
by dukester
Fri Mar 29, 2019 3:44 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

@Lutz Thanks for all the trouble you went through!! Unfortunately, after doing all your recommendations, nothing changed! No Cigars!! I still get the same response from Apache: [Fri Mar 29 09:35:53.040187 2019] [http:error] [pid 10048:tid 1076] [client 127.0.0.1:51447] AH02429: Response header name ...
by dukester
Wed Mar 27, 2019 5:28 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

Both are set. I've installed newlisp in c:\bin\newlisp to make sure that I did not have future issues with spaces in directory names like "Program Files" etc. So NEWLISPDIR points to c:\bin\newlisp. PROGRAMFILES is set to "Program Files". I changed it to c:\bin\newlisp. The change did not fix my pro...
by dukester
Wed Mar 27, 2019 3:28 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

@ralph.ronnquist
You bet that I have an Hex editor!! I don't see any garbage - which puzzles me. I've included a screen capture of the output. Now I'm wondering what Apache is choking on!! Pain in the Pa-toot!! LOL
by dukester
Wed Mar 27, 2019 10:35 am
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

@lutz Thx, but that does not work either. Sorry!
by dukester
Wed Mar 27, 2019 3:12 am
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

Nope! No cigar! LOL
by dukester
Wed Mar 27, 2019 3:04 am
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

[quote="xytroxon"]I think the problem is that the command-line prompt and initial copyright banner output needs to be suppressed.

Change the line:

Code: Select all

#!C:\bin\newlisp\newlisp.exe
To:

Code: Select all

#!C:\bin\newlisp\newlisp.exe -c
Thx! I'll give that a shot!!
by dukester
Tue Mar 26, 2019 11:41 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

@rickyboy All good stuff! But if Apache was being a bad-ass, it would be doing so with my Perl, Python and Ruby scripts! Even old CLISP scripts run well. Get where I'm going with this? ;-)

Thanks for the heads-up regarding Apache security stuff!
by dukester
Tue Mar 26, 2019 11:02 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

@ralph.ronnquist - I'm sure that you are absolutely correct. However, I've never had to do what you are suggesting. Most of my experience has been on Apache using from CL to Perl to crank out CGI stuff. Newlisp is the only interpreter that has ever given me fits with these type of issues - given tha...
by dukester
Tue Mar 26, 2019 9:55 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

ralph.ronnquist wrote:You might want to try the initial line

Code: Select all

Status: 200 OK
Don't know what you mean!
by dukester
Tue Mar 26, 2019 8:47 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Re: Newlisp-Apache-CGI Issues Again

Looks suspiciously like the ole windoze versus unix line ending issue/difference. I’d check that before moving on to anything else. Nope! It's a newlisp issue - just like back in 2015. I tried your suggestion, even though I knew it wouldn't work. And it didn't. Lutz will have to get involved I'm su...
by dukester
Tue Mar 26, 2019 1:28 pm
Forum: newLISP and the O.S.
Topic: Newlisp-Apache-CGI Issues Again
Replies: 29
Views: 3209

Newlisp-Apache-CGI Issues Again

PS C:\bin\newlisp> newlisp -v newLISP v.10.7.1 64-bit on Windows IPv4/6 UTF-8 libffi. Running Apache2.4 on a Win10 box. Apache is choking - once again - on the header sent by newlisp: Content-type' contains invalid characters, aborting request Lutz fixed a similar issue back in 2015, but it seems to...
by dukester
Thu Aug 24, 2017 11:50 am
Forum: newLISP in the real world
Topic: dolist on main-args problem
Replies: 6
Views: 2174

Re: dolist on main-args problem

Thx Ralph!! Much obliged ...

I now see how I confused the "break expression" with "sub list" expression!

Learning any flavour of LISP as been such a challenge for me! But at my age, the struggle might be an excellent way to keep the "leetle grey cells" flashing and sparking! LOL
by dukester
Thu Aug 24, 2017 4:28 am
Forum: newLISP in the real world
Topic: dolist on main-args problem
Replies: 6
Views: 2174

Re: dolist on main-args problem

So how does this reconcile with the code snippet

Code: Select all

(dolist (x (2 (main-args)))
that you kindly volunteered in your previous post - which works like a charm?
by dukester
Thu Aug 24, 2017 1:17 am
Forum: newLISP in the real world
Topic: dolist on main-args problem
Replies: 6
Views: 2174

Re: dolist on main-args problem

Thanks for the reply Ron!

The manual says:
dolist
syntax: (dolist (sym list|array [exp-break]) body)

(dolist (x '(a b c d e f g) (= x 'e)) ; prints: abcd
(print x))
The optional "exp break" appeared to follow all the other arguments!

How am I interpreting the manual incorrectly?
by dukester
Thu Aug 24, 2017 12:54 am
Forum: newLISP in the real world
Topic: set - setf - setq woes
Replies: 6
Views: 1862

Re: set - setf - setq woes

@s.v. Thanks! I will read your reply carefully and as an exercise, I will fabricate some examples to prove your points.

I have been using (set 'a-symbol blah blah) as an equivalent to (setq a-symbol blah blah). Maybe that was a bad assumption!

Thx for the input ...
by dukester
Wed Aug 23, 2017 9:18 pm
Forum: newLISP in the real world
Topic: dolist on main-args problem
Replies: 6
Views: 2174

dolist on main-args problem

I have this test code: #!c:\bin\newlisp\newlisp.exe (println (main-args 2)) ;; works OK (dolist (x (main-args)) (println $idx ":" x)) (exit) The above code works fine! BUT - when I ask dolist to use a "break expression", I'm making it choke and I don't know why! So if I do: (dolist (x (main-args 2))...
by dukester
Wed Aug 23, 2017 3:49 am
Forum: newLISP in the real world
Topic: set - setf - setq woes
Replies: 6
Views: 1862

Re: set - setf - setq woes

vetelko wrote:Description in manual is short and simple
http://www.newlisp.org/downloads/newlis ... .html#setf
I did RTFM !! Examples with extra skinny explanations ! Thanks anyway! +1
by dukester
Tue Aug 22, 2017 4:58 am
Forum: newLISP in the real world
Topic: set - setf - setq woes
Replies: 6
Views: 1862

Re: set - setf - setq woes

Hmm, did you have the variable quoted maybe? Are you asking if I used setf/setq and quoted the symbol as well? I'm not sure ... :/ Regardless of how I screwed up though (and I did ) , I'm looking for extra simple directions as to when to use 'set' , 'setf' and 'setq' so that I won't go down that ro...